September 20th, 2017

Rabbid

PHP-FPM не "видит" модулей Apache

Прошу помощи у коллективного разума!

Есть стандартный LAMP с WordPress на борту.
php-fpm установлен по умолчанию, слушает 127.0.0.1:9000

В конфигурации модуля пыха для Апача указано SetHandler proxy:fcgi://127.0.0.1:9000
Всё работало до прекрасного момента, когда наши девы решили нахлобучить плагин для вордпресса w3 total cache.
Плагин устанавливается нормально, но выкидывает ошибки при проверке системы:
mod_deflate: Not detected (required for disk enhanced Page Cache and Browser Cache)
mod_env: Not detected (required for disk enhanced Page Cache and Browser Cache)
mod_expires: Not detected (required for disk enhanced Page Cache and Browser Cache)
mod_filter: Not detected (required for disk enhanced Page Cache and Browser Cache)
mod_ext_filter: Not detected (required for disk enhanced Page Cache and Browser Cache)
mod_headers: Not detected (required for disk enhanced Page Cache and Browser Cache)
mod_mime: Not detected (required for disk enhanced Page Cache and Browser Cache)
mod_rewrite: Not detected (required for disk enhanced Page Cache and Browser Cache)
mod_setenvif: Not detected (required for disk enhanced Page Cache and Browser Cache)


Сами по себе модули в конфигурации Апача, естественно, есть.
При тестировании на чистой машине обратил внимание, что тестовая страница с phpinfo() не показывает ту часть, где описан apache2handler со всеми вызванными модулями.
Замена директивы на SetHandler application/x-httpd-php включает часть с apache2handler, и показывает вызванные модули Апача.

Теперь вопрос - как мне сделать так, что бы пых видел модули Апача при обработке через fcgi?

Гугл ничего вразумительного не подсказал.