Miller777 (miller777) wrote in ru_sysadmins,
Miller777
miller777
ru_sysadmins

Мистика с Mikrotik RB951Ui-2HnD и телефоном

Прошу помощи у знатоков Mikrotik.

Ситуация: сменил дома роутер, был TP-Link, поставил Mikrotik RB951Ui-2HnD. До смены роутера все было нормально.

Настроил Wi-Fi и прочее. Все настроено так, как было на старом роутере: SSID, шифрование.

И стало наблюдаться следующее: мой телефон подключается к Wi-Fi, держит подключение 2-3 минуты (это я погорячился, на самом деле - 10 минут ровно), после чего все коннекты пропадают. Не работают браузер, почта, мессенджеры, везде выводится сообщение: "отсутствует подключение к интернету". При этом значок подключения к Wi-Fi горит, пинги до роутера идут, а во внешний мир - нет. И в браузере на телефоне можно открыть 192.168.0.1 и зайти в управление роутером, но подключение именно к интернет отсутствует.

На других устройствах, подключаемых по Wi-Fi, все в порядке. Интернет не пропадает. Проверено на 4-х устройствах. Проблема стала возникать только у меня.

На всякий случай:

Телефон: Dexp Ixion ML-5, Android 4.4, кастомная прошивка.

Конфигурация Mikrotik:

# jan/03/2016 22:33:04 by RouterOS 6.33.3
# software id = 15W1-9PD5
#
/interface bridge
add admin-mac=4C:5E:0C:BC:1D:9D auto-mac=no mtu=1500 name=bridge-local
/interface ethernet
set [ find default-name=ether1 ] mac-address=00:11:09:8A:D7:CA name=\
ether1-gateway
set [ find default-name=ether2 ] mac-address=4C:5E:0C:BC:1D:9D name=\
ether2-master-local
set [ find default-name=ether3 ] mac-address=4C:5E:0C:BC:1D:9E master-port=\
ether2-master-local name=ether3-slave-local
set [ find default-name=ether4 ] mac-address=4C:5E:0C:BC:1D:9F master-port=\
ether2-master-local name=ether4-slave-local
set [ find default-name=ether5 ] mac-address=4C:5E:0C:BC:1D:A0 master-port=\
ether2-master-local name=ether5-slave-local
/interface wireless
set [ find default-name=wlan1 ] adaptive-noise-immunity=ap-and-client-mode \
band=2ghz-b/g/n channel-width=20/40mhz-Ce country=russia disabled=no \
distance=indoors frequency=2442 hw-protection-mode=rts-cts mode=ap-bridge \
name=wlan2 ssid=Miller777WiFi tx-power-mode=all-rates-fixed \
wireless-protocol=802.11 wmm-support=enabled
/ip neighbor discovery
set ether1-gateway discover=no
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk group-ciphers=\
tkip,aes-ccm mode=dynamic-keys unicast-ciphers=tkip,aes-ccm \
wpa-pre-shared-key=46512924651292 wpa2-pre-shared-key=46512924651292
/ip ipsec proposal
set [ find default=yes ] enc-algorithms=aes-128-cbc
/ip pool
add name=dhcp ranges=192.168.0.50-192.168.0.100
/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge-local name=default
/interface bridge port
add bridge=bridge-local interface=ether2-master-local
add bridge=bridge-local
add bridge=bridge-local interface=wlan2
/ip address
add address=192.168.0.1/24 interface=ether2-master-local network=192.168.0.0
/ip dhcp-client
add comment="default configuration" dhcp-options=hostname,clientid disabled=\
no interface=ether1-gateway
/ip dhcp-server network
add address=192.168.0.0/24 comment="default configuration" dns-server=\
192.168.0.1,8.8.8.8,8.8.4.4 gateway=192.168.0.1 netmask=24
add address=192.168.1.0/24 gateway=192.168.1.1 netmask=24
/ip dns
set allow-remote-requests=yes servers=8.8.8.8
/ip dns static
add address=192.168.0.1 name=router
/ip firewall filter
add chain=forward comment="default configuration" connection-state=\
established
add chain=forward comment="default configuration" connection-state=related
add action=drop chain=forward comment="default configuration" \
connection-state=invalid
add chain=input protocol=icmp
add chain=input connection-state=established
add chain=input connection-state=related
add action=drop chain=input in-interface=ether1-gateway
/ip firewall nat
add action=masquerade chain=srcnat comment="default configuration" \
out-interface=ether1-gateway
/ip ipsec policy
set 0 dst-address=0.0.0.0/0 src-address=0.0.0.0/0
/system clock
set time-zone-autodetect=no time-zone-name=Europe/Moscow
/system ntp client
set enabled=yes primary-ntp=188.134.70.129 secondary-ntp=46.8.40.31
/system routerboard settings
set protected-routerboot=disabled
/tool mac-server
set [ find default=yes ] disabled=yes
add interface=ether2-master-local
add interface=wlan2
/tool mac-server mac-winbox
set [ find default=yes ] disabled=yes
add interface=ether2-master-local
add interface=wlan2




Все выглядит так, как будто Mikrotik через 2-3 минуты закрывает именно этому телефону выход наружу. Никаких правил в файерволе не настроено.

Куда копать?

UPD: Проблема решена.

Совет заглянуть в лог Mikrotik был весьма кстати. Заглянул бы сразу - не пришлось бы писать пост.

Проблема была в настройках DHCP сервера. Адрес выдавался на 10 минут, после чего "deassigned" (как это корректо по-русски? Отбирался?), затем выделялся снова - тот же самый. По времени - как раз совпадает с обрывом связи.

Видимо, остальные устройства как-то эту ситуацию умеют корректно обрабатывать, а мой телефон - не умеет. Почему так - это уже другая загадка. Почему после переназначения адреса можно зайти на 192.168.0.1, но нельзя выйти наружу - тоже непонятно. Буду рад пояснениям.

Почему именно 10 минут по умолчанию стояло в Mikrotik на аренду адреса - тоже не знаю. В старых прошивках такого, вроде, не было. Поменял на 3 дня, вот уже 30 минут - все нормально.

Спасибо всем отклинувшимся!
Subscribe
  • Post a new comment

    Error

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

    When you submit the form an invisible reCAPTCHA check will be performed.
    You must follow the Privacy Policy and Google Terms of use.
  • 15 comments